Android app currently unavailable on Google Play.
Incident Report for Digidentity
Resolved
Our Android app is available for download again via Google Play. We apologise for any inconvenience.
Posted Jun 15, 2022 - 07:55 UTC
Identified
Our Android app is currently not available for download via Google Play. We're working to ensure that our app is available again, ASAP.
The iOS app is not affected.
We're sorry for any inconvenience caused.
Posted Jun 14, 2022 - 14:10 UTC
This incident affected: Registration Services.