Intermittent issues verifying KvK details
Incident Report for Digidentity
Resolved
The KvK has reported that the incident with their services has been resolved. Registration services should be working as expected again.
Posted Jan 11, 2023 - 19:22 UTC
Identified
We have identified an issue causing some KvK-numbers to be rejected during new product registrations.
Posted Jan 11, 2023 - 16:15 UTC
This incident affected: Registration Services.